Setup Eclipse Part 2/2

Posted by Vexillum on May 05, 2012

In this tutorial we are going to install a plugin for Eclipse called  “Eclipse Git Plugin” and pull the latest verion of AndEngine (GLES2).

To install GLES2 I would advise you to get the “Eclipse Git Plugin”

  1. To install the “Eclipse Git Plugin”
    1. Select “Help”->”Install New Software”.
    2. Click Add, in the top-right corner.
      1. Enter a name e.g. “Eclipse Git Plugin” and the Location http://download.eclipse.org/egit/updates-1.3/
    3. Restart Eclipse

import Projects from Git

  1. Import GLES2
    1. Select “Import”->”Projects from Git”->”URI”->Enter URI
      1. https://github.com/nicolasgramlich/AndEngine.git
      2. all AndEngine libraries
        1. https://github.com/nicolasgramlich/AndEngine.git
          https://github.com/nicolasgramlich/AndEngineExamples.git
          
          https://github.com/nicolasgramlich/AndEngineAugmentedRealityExtension.git
          https://github.com/nicolasgramlich/AndEngineMODPlayerExtension.git
          https://github.com/nicolasgramlich/AndEngineSVGTextureRegionExtension.git
          https://github.com/nicolasgramlich/AndEnginePhysicsBox2DExtension.git
          https://github.com/nicolasgramlich/AndEngineTexturePackerExtension.git
          https://github.com/nicolasgramlich/AndEngineMultiplayerExtension.git
          https://github.com/nicolasgramlich/AndEngineLiveWallpaperExtension.git
          https://github.com/nicolasgramlich/AndEngineTMXTiledMapExtension.git
          https://github.com/nicolasgramlich/AndEngineScriptingExtension.git
    2. Select “GLES2″ and Import Projects
      1. If you get the error “Unable to resolve target ‘android-XX'”
        1. Check if you have installed all the android targets (2.2-4.0)
      2. If you get the error “Android requires compiler compliance level 5.0 or 6.0. Found ‘1.4’ instead. Please use Android Tools > Fix Project Properties.”
        1. Right click the project ->”Java Compiler”
          1. Set “Compiler compliance level” to 1.6
  2. You should now be able to use GLES2